[ntp:questions] ntp-4.2.6p5 on Win 7 x64

David Taylor david-taylor at blueyonder.co.uk.invalid
Tue Jul 22 18:29:01 UTC 2014


On 22/07/2014 16:53, Nick wrote:
[]
> ntp runs well on Mint 17 and the drift is reported to be -17ppm.
>
> ntp does not run well on Win 7 x64 and the drift is reported to be +493ppm.
>
> What makes ntpd think that the frequency error on Windows is +493?
[]
> Any ideas chaps?

Nick, I have seen (some time back) NTP run a little wild when the drift 
file is so near the limit.  You aren't overclocking, I suppose?  Anyway, 
try deleting the drift file and letting NTP run for more than an hour.

If there's something which is causing your PC to have an incorrect clock 
in Windows, you /may/ be able to compensate using an environment 
variable as described here:

   http://www.satsignal.eu/ntp/setup.html#broken-clock

Oh, it looks like you've considered that already, but have you tried 
setting NTPD_TICKADJ_PPM?

I suppose there's no issue with power-saving, or a spread-spectrum BIOS?

I know of one other PC where it was impossible to get NTP to work 
properly (not tested with Linux) and the only solution was to stop and 
restart the NTP service every 10 minutes or so!

-- 
Cheers,
David
Web: http://www.satsignal.eu



More information about the questions mailing list