[ntp:questions] ntp-4.2.6p5 on Win 7 x64

Brian Inglis Brian.Inglis at SystematicSw.ab.ca
Fri Jul 25 05:08:50 UTC 2014


On 2014-07-24 10:41, Nick wrote:
> On Tue, 22 Jul 2014 19:29:01 +0100, David Taylor wrote:
>
>>
>> Nick, I have seen (some time back) NTP run a little wild when the drift
>> file is so near the limit.  You aren't overclocking, I suppose?  Anyway,
>> try deleting the drift file and letting NTP run for more than an hour.
>
> No overclocking on this machine!  Deleting the drift file fixes it.
>
>> If there's something which is causing your PC to have an incorrect clock
>> in Windows, you /may/ be able to compensate using an environment
>> variable as described here:
>>
>>     http://www.satsignal.eu/ntp/setup.html#broken-clock
>>
>> Oh, it looks like you've considered that already, but have you tried
>> setting NTPD_TICKADJ_PPM?
>
> Yes I tried that and it didn't seem to matter what value was set the
> performance got worse.  The jitter is so bad.
>
>> I suppose there's no issue with power-saving, or a spread-spectrum BIOS?
>>
>
> Funny you should say that.  Although all the PM is turned off in the BIOS
> I found a sneaky setting via Control Panel called Power Management,
> Minimum Processor State.  Changing this from 5% to 100% reduced the DPC
> latency dramatically and improved NTP's performance.

Check BIOS for things like Spread spectrum speed/frequency and set Off,
and disable Intel SpeedStep, Dynamic Acceleration (IDA), TurboBoost, AMD
Cool'n'Quiet, PowerNow, TurboCore processor speed up or slow down states,
basically anything but G0, S0, C0, P0, and enable Wake on anything
(use belt and suspenders!)

Select Control Panel/Power Options, Select power plan High Performance,
select Change plan settings, Put the computer to sleep Never, select
Change advanced power settings, ensure High Performance (active) selected,
set Hard disk/Turn off after 60 minutes (never happens), various others to
Maximum Performance, Sleep/after Never, /Allow hybrid sleep Off, /Hibernate
after Never, /Allow wake timers Enable, USB/selective suspend setting Disabled,
Power Button/Sleep button Do nothing, Link State Power Management Off, Processor
power management/Minimum 100%, /System cooling policy Active, /Maximum 100%,
Multimedia settings/When sharing Prevent idling to sleep, /When playing video
Optimize video quality.

> Offsets and jitters now in the 10's of ms.

Ensure in Task Manager that ntpd runs Realtime priority and set Affinity to
last CPU, to improve stability.

-- 
Take care. Thanks, Brian Inglis


More information about the questions mailing list