[ntp:questions] error message on startup

Brian Inglis Brian.Inglis at SystematicSw.ab.ca
Sun Mar 2 02:10:55 UTC 2014

On 2014-02-28 10:00, Dwayne Hottinger wrote:
> Ive just finished upgrading ntp to version Ver. 4.2.7p421 in order to keep
> from becoming a ddos member.  I changed the init.d script to point to
> /usr/local/bin/ntp if I run the script I get the following error message
>   ntpd error:  'ntp' is not a recognizable number.  I can start manually
> using:
>   /usr/local/bin/ntpd -u ntp -p /var/run/ntpd.pid and it seems to run.
>   However, Im not able to sync with my internal network.  I added the
> following to my ntp.conf file:
> ###Added 02/28/2014 for security and ddos should prohibit outside access
> restrict default ignore
> restrict
> ##For internal 10. network and public ips allows ourservers to still work
> restrict mask nomodify notrap
> I most certainly am missing something somewhere since my internal clients
> cant sync with my ntp server.  Can anyone nudge me in the right direction?

You don't say which distro/platform/version/user you are running on/as,
nor whether you installed a distro package or built your own, and under
which user.

You normally need to run as root to access privileged ports < 1024
and run under another userid.

You may need to move the executable to a secure directory if you want
to make it and run it as setuserid nowadays, given the privilege
escalation mitigation measures being taken by some systems.
These effects may also need to be checked for your release and setup.

Check passwd, and/or nsswitch.conf and network user directory;
init.d script location, permissions, any userid specified in
init script, init startup order relative to service dependencies,
possibly chkconfig settings in the script and on the system.

Take care. Thanks, Brian Inglis

More information about the questions mailing list