[ntp:questions] Help with cross-compiling NTP for the Raspberry Pi requested

David Taylor david-taylor at blueyonder.co.uk.invalid
Sat Mar 8 12:14:39 UTC 2014


Per, Brian, Harlan,

Thank you all for your help.

Per, you are correct to ask whether configure worked with 
"--host=arm-bcm2708hardfp-linux-gnueabi-".  It did not, and as you and 
Harlan noted the trailing "-" had to be dropped.


The following script successfully produces a binary which runs on the 
Raspberry Pi, but with one issue remaining about which I will write 
separately.

_____________________________________________
PATH=/home/david/kernel/tools/arm-bcm2708/arm-bcm2708hardfp-linux-gnueabi/bin/:$PATH

export PATH

make clean

../configure --host=arm-bcm2708hardfp-linux-gnueabi 
--build=x86_64-unknown-linux --enable-linuxcaps

make
make DESTDIR=`pwd`/:Built install

ls -l :Built/usr/local/bin
ls -l :Built/usr/local/sbin
file :Built/usr/local/sbin/ntpd
_____________________________________________

(the PATH and ../configure are all on one line).

==============================================================

The one remaining issue is this.  When starting the NTP server on the 
Raspberry Pi I get the error message:

[....] Starting NTP server: ntpd/usr/sbin/ntpd: The 'user' option
has been disabled. -- built without --enable-clockctl or
--enable-linuxcaps or --enable-solarisprivs

and I note that when I compile on the Raspberry Pi I do use:

   ./configure --enable-linuxcaps

(yes, the linuxcaps was mis-spelt earlier) and the configure takes 11-15 
minutes on the RPi.  (there also seems to be duplication, e.g. in 
testing for the size of integers....).  However, you will see from my 
script above that I do have the same option specified in the 
../configure line for cross-compiling, but it seems to be ignored.  I 
tried it both at the start and at then# end of that line.

So much more progress than before, now perhaps 80% of the way there 
thanks to all your help.

-- 
Cheers,
David
Web: http://www.satsignal.eu



More information about the questions mailing list