[ntp:questions] Help with cross-compiling NTP for the Raspberry Pi requested

Mike George mgeorge at tuffmail.us
Sat Mar 8 17:03:38 UTC 2014


Maybe your build environment is missing libcaps.

On my ubuntu machine that I built NTP on I installed
Not sure if I needed the -dev but I didn't try without it.


On 3/8/2014 07:14, David Taylor wrote:
> ==============================================================
> The one remaining issue is this.  When starting the NTP server on the 
> Raspberry Pi I get the error message:
> [....] Starting NTP server: ntpd/usr/sbin/ntpd: The 'user' option
> has been disabled. -- built without --enable-clockctl or
> --enable-linuxcaps or --enable-solarisprivs
> and I note that when I compile on the Raspberry Pi I do use:
>   ./configure --enable-linuxcaps
> (yes, the linuxcaps was mis-spelt earlier) and the configure takes 
> 11-15 minutes on the RPi.  (there also seems to be duplication, e.g. 
> in testing for the size of integers....).  However, you will see from 
> my script above that I do have the same option specified in the 
> ../configure line for cross-compiling, but it seems to be ignored.  I 
> tried it both at the start and at then# end of that line.
> So much more progress than before, now perhaps 80% of the way there 
> thanks to all your help.

More information about the questions mailing list