[ntp:questions] Synchronizing contrived time

William Unruh unruh at invalid.ca
Sun Mar 16 18:17:02 UTC 2014


On 2014-03-16, Amit Dor-Shifer <amit.dor.shifer at gmail.com> wrote:
> David: I'm using '-c /path/to/ntp.conf'.
>
> William: Thanks. Still, with the added conf you suggest, client won't
> accept a sync from the server. Seems like the stratum setting I've added
> isn't taking effect.

Yes. You told us (below) that ntpd cannot read your ntp.conf file. And
you are surprised that the content of that file is not taking effect? 
Really, you need to read the error messages. 
change the premission 
chmod -R a+rX /tmp/test_ntpd
to make sure it can read that file. 


>
><server>
> amit at zelda:~$ sudo date -s "$(date) - 50 minutes"
> Sun Mar 16 18:32:14 EST 2014
> amit at zelda:~$ cat /tmp/test_ntpd/ntp.conf
> server 127.127.1.0 minpoll 4 maxpoll 4
> fudge 127.127.1.0 stratum 10
> amit at zelda:~$ sudo /usr/sbin/ntpd -g -c /tmp/test_ntpd/ntp.conf
> ...
></server>
>
><client>
> $ date
> Sun 16 Mar 2014 19:31:55 EST
> $ sudo ntpdate 192.168.1.11
> Password:
> 16 Mar 19:32:10 ntpdate[64775]: no server suitable for synchronization found
> $ date
> Sun 16 Mar 2014 19:32:12 EST
> $ sudo ntpdate -d 192.168.1.11
> 16 Mar 19:32:20 ntpdate[64781]: ntpdate 4.2.6 at 1.2089-o Fri May 28 01:20:57
> UTC 2010 (1)
> Looking for host 192.168.1.11 and service ntp
> host found : 192-168-1-11.tpgi.com.au
> transmit(192.168.1.11)
> receive(192.168.1.11)
> transmit(192.168.1.11)
> receive(192.168.1.11)
> transmit(192.168.1.11)
> receive(192.168.1.11)
> transmit(192.168.1.11)
> receive(192.168.1.11)
> transmit(192.168.1.11)
> 192.168.1.11: Server dropped: strata too high
> server 192.168.1.11, port 123
> stratum 16, precision -23, leap 11, trust 000
> refid [192.168.1.11], delay 0.02779, dispersion 0.00002
> transmitted 4, in filter 4
> reference time:    00000000.00000000  Mon, Jan  1 1900 10:00:00.000
> originate timestamp: d6cfd431.bdd846e0  Sun, Mar 16 2014 18:41:37.741
> transmit timestamp:  d6cfe014.459a1fd1  Sun, Mar 16 2014 19:32:20.271
> filter delay:  0.02916  0.02809  0.02808  0.02779
>          0.00000  0.00000  0.00000  0.00000
> filter offset: -3042.53 -3042.53 -3042.53 -3042.53
>          0.000000 0.000000 0.000000 0.000000
> delay 0.02779, dispersion 0.00002
> offset -3042.531538
></client>
>
> Running the server with '-d' yields the following (otherwise silent) error:
>
> amit at zelda:~$ sudo /usr/sbin/ntpd -d -g -c /tmp/test_ntpd/ntp.conf
> ntpd 4.2.6p3 at 1.2290-o Tue Jun  5 20:12:08 UTC 2012 (1)
> 16 Mar 20:47:24 ntpd[5042]: proto: precision = 0.208 usec
> event at 0 0.0.0.0 c01d 0d kern kernel time sync enabled
> 16 Mar 20:47:24 ntpd[5042]: getconfig: Couldn't open
></tmp/test_ntpd/ntp.conf>
>
> strace-ing it shows:
> open("/tmp/test_ntpd/ntp.conf", O_RDONLY) = -1 EACCES (Permission denied)
>
> amit at zelda:~$ ll /tmp/test_ntpd/ntp.conf
> -rwxrwxrwx 1 amit amit 69 Mar 16 20:17 /tmp/test_ntpd/ntp.conf*

And what are the permissions on /tmp/test_ntpd?

>
>
>
>
> On Sun, Mar 16, 2014 at 8:10 PM, David Woolley <
> david at ex.djwhome.demon.invalid> wrote:
>
>> On 15/03/14 23:55, Amit Dor-Shifer wrote:
>>
>>> William, earlier along this post, I was asking (David, specifically) for a
>>> suggested fix to this error.
>>> Can you offer a possible fix?
>>>
>>>  I thought that had been answered; you are using the wrong option to
>> specify the custom configuration file on the server.
>>
>>
>> _______________________________________________
>> questions mailing list
>> questions at lists.ntp.org
>> http://lists.ntp.org/listinfo/questions
>>



More information about the questions mailing list