[ntp:questions] NTP shared memory driver

Rob nomail at example.com
Mon Sep 15 11:24:07 UTC 2014

Claudio Persico <clouddese at gmail.com> wrote:
>> Try with a time within 4 hours of correct, or closer.
> I tried also with 400 seconds, but still no success: NTP doesn't update system time despite all seems to be configured correctly.
> The way in which I'm updating the shared memory segment is taking the current time and subtracting 400 seconds. Should there be a problem with this approach?

Not in particular.
But in general, you can say that anything you try to make ntpd do things
that would not happen in correct operation are sometimes rejected, sometimes
result in unexpected action.

It happens time after time that people post here with "I installed ntpd
and now I want to test it so I set my clock to the wrong value while it
was running, or I feed it time from a system with incorrect time, and
it does not act as expected".

Apparently, people write test scenarios beforehand and write expected
results, then they test and find it does not work that way, and come here
to ask why.

It appears that ntpd was not written with tests like that in mind, and
they cannot reliably be performed.  I guess you have to live with that.

More information about the questions mailing list