[ntp:questions] GPS Offset problems

Brian Inglis Brian.Inglis at SystematicSw.ab.ca
Sat Jan 31 04:17:46 UTC 2015


On 2015-01-30 18:09, utahcbs at gmail.com wrote:
> I built a GPS (HP 58503) based NTP server about 10 years ago.  It worked fine but eventually died, and I built a replacement.  But I am having no end of problems with long offsets.
> The new machine is Linux-based with a Z3801 and PPS.  It consistently shows an offset as compared to other NTP clocks.
> After about a week of trying to figure it out, I got desperate and bought a used Datum Tymserv 2100 as a stopgap until I could figure out the problem.  It worked great until recently, and now it has a 1-second offset as compared to the world.
> Both servers share a common antenna (Symmetricom GPS LT) on a HP/Symmetricom splitter.  Obviously I make certain that I have good GPS signal and everything is locked.
> I recently purchased a SECOND Datum 2100 and it had the exact same offset.  So I ran a new wire and hooked it to a different antenna of the same model, same offset.
> So I changed to a different antenna, same offset -1 second as compared with known good network servers.
> Here is what I have running in this example:
> Freiburg = Datum 2100
> Augsburg = Linux server with HP Z3801, shared with Freiburg's antenna
> Shaun = Datum 2100 on different antenna
> When I go into Augsburg, all seems good (PPS currently disabled), but it is off by nearly a second in the other direction, +1 second from known-good servers so +2 seconds from my other servers.
> Clearly I am doing something wrong.  I've been beating my head against a wall for quite a while trying to figure it out.  I have another system with a Z3805 that has an offset of 16000 with a good lock.

See recent posts on timenuts archives about Datum Tymserve 2100 et al early leap second, checks, and fixes.

-- 
Take care. Thanks, Brian Inglis


More information about the questions mailing list