[ntp:questions] Need help on NTP client

Gao gao at pztop.com
Wed Jul 22 17:28:30 UTC 2015


Hello list,

I have a local NTP server setup in my office LAN. It is a CentOS6 VM. On 
the server ntpd works fine. Now I build a new CentOS7 server and it 
can't sync with any of the NTP server, including my local server.

Here is my local NTP server(ovpn.sjv.lan, IP:192.168.123.46):

[root at ovpn ~]# ntpq -p
      remote           refid      st t when poll reach   delay offset  
jitter
==============================================================================
+ntp1.torix.ca   .PPS.            1 u   53 1024  377   68.759 -0.453  11.657
*ntp2.torix.ca   .PPS.            1 u  699 1024  377   72.491 3.638   0.412
+69.28.67.44     18.26.4.105      2 u  101 1024  357   64.888 -1.005   2.151
-euro-shared.oln 142.3.100.2      2 u  621 1024  377  100.648 15.585  11.371
  LOCAL(0)        .LOCL.          10 l  18h   64    0    0.000 0.000   0.000

[root at ovpn ~]# iptables -L -n
Chain INPUT (policy ACCEPT)
target     prot opt source               destination
ACCEPT     udp  --  0.0.0.0/0            0.0.0.0/0           udp dpt:123
ACCEPT     udp  --  0.0.0.0/0            0.0.0.0/0           udp spt:123

###############################################

Now the new installed CentOS7(test.sjv.lan):

firewalld and SELinux has been disabled.

[root at test log]# ntpq -p
      remote           refid      st t when poll reach   delay offset  
jitter
==============================================================================
  ovpn.sjv.lan    .INIT.          16 u    -   64    0    0.000 0.000   0.000
  kirdu.smartacti .INIT.          16 u    -   64    0    0.000 0.000   0.000
  ntp3.torix.ca   .INIT.          16 u    -   64    0    0.000 0.000   0.000
  euro-shared.oln .INIT.          16 u    -   64    0    0.000 0.000   0.000
  bitdonut.co     .INIT.          16 u    -   64    0    0.000 0.000   0.000

[root at test log]# cat /etc/ntp.conf | egrep -v "(^#.*)"

driftfile /var/lib/ntp/drift

restrict default nomodify notrap nopeer noquery

restrict 127.0.0.1
restrict ::1

server ovpn.sjv.lan iburst
server 0.centos.pool.ntp.org iburst
server 1.centos.pool.ntp.org iburst
server 2.centos.pool.ntp.org iburst
server 3.centos.pool.ntp.org iburst

includefile /etc/ntp/crypto/pw

keys /etc/ntp/keys

disable monitor




[root at test log]# ntpdate -q ovpn.sjv.lan
server 192.168.123.46, stratum 2, offset -5.304602, delay 0.02580
22 Jul 10:24:37 ntpdate[12081]: step time server 192.168.123.46 offset 
-5.304602 sec

################################################

I don't know what to do. I tried to turn off firewall on both nodes. The 
"ntpq -p" just wont show me any sign of reach the servers, both local 
and public.

Please help.



Gao





-- 



More information about the questions mailing list