[ntp:questions] NTP 4.2.8p9 installer for Windows available

Brian Inglis Brian.Inglis at SystematicSw.ab.ca
Tue Nov 22 17:50:39 UTC 2016


On 2016-11-22 09:06, Martin Burnicki wrote:
> An updated GUI installer for ntp-4.2.8p9 for Windows is now
> available at
> https://www.meinbergglobal.com/english/sw/ntp.htm#ntp_stable
>
> This NTP version contains some security fixes, see:
> http://support.ntp.org/bin/view/Main/SecurityNotice#Recent_Vulnerabilities
> for details. It is explicitly recommended to upgrade earlier
> installations to this version.

Does this release also include loopback-ppsapi-provider.dll?

The dates on the installed DLL match your initial 4.2.8
release date, so it is not clear whether it has just not
changed since then, or not been provided since then:
Access: 2015-01-31 14:26:58.746040500 -0700
Modify: 2014-12-22 06:21:16.000000000 -0700
Change: 2015-01-31 14:26:58.761640500 -0700
  Birth: 2014-12-22 06:21:16.000000000 -0700
whereas libeay32.dll shows:
Access: 2015-01-31 14:26:58.777240500 -0700
Modify: 2016-04-28 03:20:48.000000000 -0600
Change: 2016-07-30 00:43:58.363201800 -0600
  Birth: 2016-04-28 03:20:48.000000000 -0600

This DLL seems to be the only way to get PPS working
properly with recent (PCI) serial cards and drivers on
recent Windows releases.

Presumably for security reasons, the full path(s) must be
specified in the PPSAPI_DLLS *SYSTEM* environment variable,
on recent Windows releases.

-- 
Take care. Thanks, Brian Inglis, Calgary, Alberta, Canada

-- 
Take care. Thanks, Brian Inglis, Calgary, Alberta, Canada


More information about the questions mailing list