[ntp:questions] PPS not working on newer kernel/distros

Brandon Applegate brandon at burn.net
Mon Oct 8 23:26:45 UTC 2018


Hello,

For years I’ve have ntpd+NMEA+PPS working great.  My OS was Ubuntu server 12.04 - and then (currently) 14.04.  GPS is a Garmin LVC 18x.

I use setserial to set low_latency, I’ve reduced the NMEA sentence to bare minimum, etc.  All the usual tweaks.  All of this going into a real UART serial PCI slot board (no USB) on a full size PC.

My relevant ntp.conf for this:

server 127.127.20.0 mode 1 minpoll 4 maxpoll 4
fudge 127.127.20.0 flag1 1 flag2 0 flag3 1 time2 0.600

I decided to try to upgrade, and hit nothing but roadblocks.  So far I’ve tried both Debian 9 and Ubuntu 18.04.  What I observe is that my GPS offset steadily climbs and climbs.  It never seems to decrease.  I’ve also tried the above config with flag3 set to 0 (“soft” PPS).  In all of these cases I’ve verified with ppswatch that I have pps coming in on the port.  It really seems like something has changed in the kernel in the past few years that’s causing this.  It’s about the only thing I can think of as a variable.  I’ve tried distro ntpd packages as well as compiling a few versions of the latest source.  All with the same behavior.

Anyone have any ideas what could cause this behavior ?

--
Brandon Applegate - CCIE 10273
PGP Key fingerprint:
0641 D285 A36F 533A 73E5  2541 4920 533C C616 703A
"For thousands of years men dreamed of pacts with demons.
Only now are such things possible."



More information about the questions mailing list