[ntp:questions] Pi 4 and Ultimate hat weirdness

David Taylor davidtaylor at writeme.com
Tue Jan 26 10:42:12 UTC 2021


On 25/01/2021 17:53, Gary E. Miller wrote:
> Yo David!
>
> On Mon, 25 Jan 2021 11:03:46 +0000
> David Taylor<davidtaylor at writeme.com>  wrote:
>
>> GPSD has proved problematical, and the only satisfactory way is not to
>> use the one in the distribution, but to build from scratch.
>>
>>     https://www.satsignal.eu/raspberry-pi/UpdatingGPSD.html
> Correction, your distros gpsd packages are problematic, not gpsd.
>
> Please file issues with your upstream.
>
>> It's the PPS which matters, and for that I've found it most
>> satisfactory to use the type 22 driver.
> Since you are willing to risk the failures that gpsd prevents that
> ntpd 22 does not.
>
> RGDS
> GARY

Yes, Gary, it's that the GPSD in the distributions are almost never the
latest version with the fixes.  It's a rapidly developing piece of software.

Fortunately I've not seen any issues with using the Type 22 driver here.

Cheers,
David
--
SatSignal Software - Quality software for you
Web: https://www.satsignal.eu
Email: david-taylor at blueyonder.co.uk
Twitter: @gm8arv


More information about the questions mailing list